Web Server - SSL Error

I am setting up a new computer and am trying to configure Apex just as I had on the previous one (which is unfortunately largely unavailable now). I have turned on the web server in the Advanced properties, but when I try to access it, I get "This site can’t provide a secure connection" and "ERR_SSL_PROTOCOL_ERROR". I think I remember having to make some other changes to get this working before, but I can't remember what or find any documentation on getting the web server working.

OS: Windows 10
Windows Firewall: Currently Disabled
ApexDC version: 1.6.5

Thank you for any assistance.

Comments

  • edited September 10

    Thanks for this, will look into it. Although I don't think anything has changed in regards to SSL/TLS.

    Edit: reading your use more closely what you need to do is add a security exception (unless you have a spare domain with valid cert to use as a reverse proxy or something like that). The reason you get the security warning is that the webserver uses your client certificate for the https (which is always self signed. unless you provide a different one).

  • I'm sorry if I'm being obtuse, but "add a security exception" where exactly? What am I adding the exception to and what is the exception for (the self-signed certificate?)?

  • edited September 10

    @neoc said:
    I'm sorry if I'm being obtuse, but "add a security exception" where exactly? What am I adding the exception to and what is the exception for (the self-signed certificate?)?

    Your browser (if it gives that option), although since it says SSL_PROTOCOL_ERROR you may also need to fiddle with your browser settings (that particular error is sort of a catch all and the cause can be any of number of things). <- on the second part google is your friend.

Sign In or Register to comment.